29 julio, 2012

jQuery 2.0 JavaScript framework abandonará el soporte para IE 6, 7 y 8


Hola tod@s!

Los desarrolladores de la popular biblioteca jQuery JavaScript ha publicado recientemente una entrada en su blog con los detalles sobreel  plan de desarrollo del proyecto. En la nota, anunció planes para retirar el apoyo a versiones anteriores del navegador de Microsoft Internet Explorer Web en jQuery 2.0

La biblioteca jQuery es muy popular entre los desarrolladores Web y se utiliza en algunos de los más grandes sitios de Internet. Se ofrece una serie de métodos de conveniencia y las funciones de utilidad que simplifican enormemente la manipulación del DOM y otras tareas que son comunes en aplicaciones Web modernas.

Hay un gran número de plugins de terceros y otros marcos que se construyen en la parte superior de la funcionalidad del núcleo de jQuery, que incluye una biblioteca de interfaz de usuario HTML y un marco de desarrollo web móvil. La biblioteca jQuery es doble licenciado, disponible bajo los términos de la Licencia Pública General de GNU o la licencia MIT.

Versión 1.8, una actualización que incluirá un revisado motor de selección CSS y otras mejoras, se encuentra actualmente en fase beta y se espera que liberen pronto. Después de la versión 1.8, los desarrolladores podrán dirigir su atención a la gran reforma que está en las obras para el año 2013. Ellos quieren hacer jQuery ligero, más rápido, y más modular. Sin embargo, las limitaciones y deficiencias en versiones anteriores de Internet Explorer les impiden alcanzar sus metas.

A fin de avanzar hacia la biblioteca y mejorar la calidad de la aplicación, que han decidido abstenerse de soporte para Internet Explorer 6, 7 y 8 en jQuery 2.0. Eso les permitirá agilizar la biblioteca y colocar una gran cantidad de las soluciones y el código de caso especial que se necesita para apoyar a las versiones antiguas de IE.

Sin embargo, los desarrolladores también están tomando medidas para acomodar el número estadísticamente no insignificante de los usuarios que aún se ejecutan versiones no actualizadas de Internet Explorer. Su plan es emitir un comunicado de jQuery 1.9 en paralelo con 2,0. La serie 1.9 se ofrece compatibilidad completa con la API 2.0 (en la medida en que van a ser en gran parte intercambiables), sino que tendrá soporte completo para las versiones anteriores de IE.

La versión 1.9 también se mantiene con correcciones de errores en forma permanente. Debido a que jQuery es en gran parte maduro y completo de características, los desarrolladores creen que 1,9 y 2,0 seguirán estando en línea en el futuro previsible.

Los desarrolladores que no necesitan el soporte de legado IE podrá utilizar 2,0 y se benefician de una implementación más rápida, que no tienen que depender de hacks compatibilidad con las anteriores. Los usuarios que necesiten soporte para versiones anteriores de Internet Explorer 1.9 puede seguir utilizando. También será posible usar los comentarios condicionales de IE para garantizar que el 1,9 sólo se sirve a los usuarios que realmente lo necesitan.

Enfoque pragmático El proyecto de jQuery a eliminar el soporte de legado IE atender las necesidades de los desarrolladores web y usuarios finales. Pero también ilumina a los desafíos que pueden surgir de tener que soportar las versiones anteriores del navegador web de Microsoft.

Hasta la próxima, saludos.

0 comentarios:

Publicar un comentario